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1 Welcome
Thank you for choosing the ST Series USB Power Sensors and welcome to the Satori 
Technology User’s Guide.

This manual will guide you through the following sections:

• Software installation
• Hardware installation
• Using the software
• Getting more from your system

Introduction
The ST CW power sensors are a new series of products which connect directly to a laptop 
or desktop computer using a standard USB port, without the need for a stand alone meter. 
Measurements from the sensor can be displayed on the laptop or desktop computer or 
can be integrated into your test system with a set of user-defined software functions – 
supplied as standard.

This guide will take you through the software installation stages. Then it will outline some 
typical hardware configurations and how to get the most from your software. Finally, you 
will be shown how to integrate the sensor into your test environment.

Key Features
The key features of the ST CW power sensor are:

• Perfect for most Power measurement uses, including:
• Installation and maintenance
• Manufacturing test
• ATE
• Research & Development

• Easy to use software
• Quick configuration
• Flexible set-up and system integration
• Small, compact and rugged
• Multiple sensor support on single PC
• No reference calibration required
• Low cost alternative to tradition power measurements
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What you should have
Before you start, please check you have the following items (Refer to Figure 1 "What you 
should have” on page 4):

• ST CW power sensor (ST124SMA or ST185SMA or ST265SMA or ST40K)
• 6 feet (1.82m) USB cable (S2004-61001)
• Satori Technology software CD (S2004-80001)
• Product warranty card (S2004-90014)
• This User’s Guide (S2004-90001)

Figure 1 What you should have

If any of these items are missing or damaged, then please contact your local 
representative as soon as possible or refer to “Contacting Satori Technology” on page 59.

Warranty User’s Guide
Card

USB
Cable

CD

ST Sensor

tSa oriechno ol gy
ST124SMA CW Power Sensor

ESD
Earth ground must be connected
Max pwr +23dBm avg, +30dBm peak for 1us +/- 10.0VDC Max.

10MHz - 12.4GHz
10nW - 100mW (-50dBm to 20dBm)
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1 Installation Of Software
This chapter provides information about installing the Satori Technology power sensor 
software.

Before you start, please check your PC for software compatibility. Refer to “Minimum PC 
requirements” on page 63 for more information.

Install procedure
To install the Satori Technology software, follow these steps:

Caution Do not connect any hardware to your PC until you have installed the 
Satori Technology software.

Note If you are using Windows XP SP1, disconnect any LAN connections. This 
will prevent your PC automatically downloading the wrong USB drivers.

Do this Comment

1 Insert the CD into your PC The installation should start 
automatically.

2 (Optional) If the installation does not start 
automatically, select Start > Run and type 
d:\SatoriSensorInstallation.exe

Where D:\ is the name of your CD 
drive.

3 Select Continue Refer to Figure 2 on page 10.
9



Installation Of Software
Figure 2 Start of installation software

4 Check the software matches your sensor 
types and then select Continue

The sensor part numbers are listed 
on the side of the sensor. Refer to 
Figure 3 on page 10.

Figure 3 Check sensor part number

5 Carefully read all of the License Agreement. If 
you accept the terms and conditions of the 
license agreement, enable the Accept option 
and then select Continue

If you have any questions about 
this agreement, then please 
contact us. Refer to Figure 4 on 
page 11.

Do this Comment
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Figure 4 License agreement

6 Choose the installation location, whether you 
want a desktop icon and a shortcut added to 
your start menu, then select Continue

It is recommended that you use the 
default installation options. Refer to 
Figure 5 on page 11.

Figure 5 Installation location

7 Select Finish when the installation has 
completed

Refer to Figure 6 on page 12.

Do this Comment
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Installation Of Software
Figure 6 Installation completed

Note At the end of the installation you are asked to connect your sensor. Refer 
to “USB Installation” on page 13 for more information.

Do this Comment
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2 USB Installation
This chapter explains the process for installing and enabling the USB drivers for your ST 
CW power sensor. These drivers are required to enable effective measurement data 
transfer.

There are two USB driver installation procedures covered in this chapter – one for 
Windows® XP SP1 and the other for Windows® XP SP2. To identify which operating 
system you have on your PC, refer to “How to identify your PC operating system” on 
page 55.

Driver installation with Windows® XP SP2
This section describes how to install and configure your USB drivers on a PC with 
Windows® XP and service pack 2 (SP2) operating system.

Caution Do not connect your sensor and install the USB drivers unless you have 
installed the Satori Technology software. Refer to “Installation Of 
Software” on page 9 for more information.

Do this Comment

1 Connect your sensor to the USB port of your PC. The 
Windows Hardware Wizard starts automatically.

Refer to “How to connect 
your sensor” on page 21 
for more information.

2 Choose “No not at this time” and select Next. Refer to Figure 7 on page 
14.
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USB Installation
Figure 7 Windows hardware installation wizard

3 Choose “Install from a list or specific location 
(Advanced)” and select Next.

Refer to Figure 8 on page 
14.

Figure 8 USB Driver location

Do this Comment
14
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4 Choose “Include this location in the search”. Refer to Figure 9 on page 
15.

Figure 9 Choose the installation location

5 Browse to the following location: C:\Program 
Files\Satori\Driver.

If you have changed the 
default installation 
location, navigate to the 
Satori installation folder.

6 Select Next.

7 (Optional) During the installation Windows may check 
the driver compatibility. Select Continue Anyway.

The USB sensor driver is 
a valid driver and will not 
damage your system. 
Refer to Figure 10 on 
page 16.

Do this Comment
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USB Installation
The USB driver that is installed is a generic USB sensor driver and it is used for a range of 
USB sensors. The sensor driver installed on your PC is called FTDI FT8U2XX Device.

Driver installation with Windows® XP SP1
This section describes how to install and configure your USB drivers on a PC with 
Windows® XP and service pack 1 (SP1) operating system.

Figure 10 Continue Anyway with installation

8 The driver will now be installed.

9 Select Finish when the driver installation is complete. Windows will now 
confirm it has identified 
the USB sensor 
hardware.

Caution Disconnect any LAN connections to the PC.

Windows® XP SP1 does not provide flexible USB driver installation. The 
operating system first attempts to obtain the USB driver from an external 
source. This external driver does not provide a working connection with 
your sensor.

Do this Comment
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Do this Comment

1 Connect your sensor to the USB port of your PC. The 
Windows Hardware Wizard starts automatically.

Refer to “How to connect 
your sensor” on page 21 
for more information.

2 Choose “No not at this time” and select Next. Refer to Figure 7 on page 
14.

Figure 11 Windows hardware installation wizard

3 Choose “Install from a list or specific location 
(Advanced)” and select Next.

Refer to Figure 8 on page 
14.
17
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Figure 12 USB Driver location

4 Choose “Include this location in the search”. Refer to Figure 9 on page 
15.

Figure 13 Choose the installation location

Do this Comment
18
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Reconnect your LAN connection.

The USB driver that is installed is a generic USB sensor driver and it is used for a range of 
USB sensors. The sensor driver installed on your PC is called FTDI FT8U2XX Device.

If this is not the driver installed on your PC, refer to “How to fix “No Sensor Connected” 
problems” on page 51 for more information.

5 Browse to the following location: C:\Program 
Files\Satori\Driver.

If you have changed the 
default installation 
location, navigate to the 
Satori installation folder.

6 Select Next.

7 (Optional) During the installation Windows may check 
the driver compatibility. Select Continue Anyway.

The USB sensor driver is 
a valid driver and will not 
damage your system. 
Refer to Figure 10 on 
page 16.

Figure 14 Continue Anyway with installation

8 The driver will now be installed.

9 Select Finish when the driver installation is complete Windows will now 
confirm it has identified 
the USB sensor 
hardware.

Do this Comment
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3 Hardware Connections
This chapter provides an overview of how to connect your ST CW power sensor in your 
test environment.

How to connect your sensor
The section describes some typical connection configurations.

Connection to your PC
Connection to your PC is through a USB cable (supplied with your sensor). The ST CW 
power sensor is USB 2.0 compatible.

It is recommended that you use the USB cable supplied with your sensor.

Refer to Figure 15 "Sensor to PC connection” on page 21 for a diagram of the sensor and 
PC connection.

Figure 15 Sensor to PC connection

The maximum recommended connection length is 5m.

tSa oriechno ol gy
ST124SMA CW Power Sensor

ESD
Earth ground must be connected
Max pwr +23dBm avg, +30dBm peak for 1us +/- 10.0VDC Max.

10MHz - 12.4GHz
10nW - 100mW (-50dBm to 20dBm)

USB Cable

Your PC

ST Sensor
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Connection to your unit under test (UUT)
The ST CW power sensor has a standard SMA-m connection port.

The recommended torque for the SMA-m connection is 5 lbs/in (0.5 Nm).

Refer to Figure 16 "Typical sensor to UUT connection” on page 22 for a diagram of the 
sensor connection.

Figure 16 Typical sensor to UUT connection

Caution Do not turn the body of the sensor when connecting the sensor to a unit 
under test (UUT). To avoid internal sensor damage, connect and 
disconnect the sensor by turning the metal nut only.

Caution Ensure that you do not apply any excessive force on the sensor once it 
has been connected.

tSa oriechno ol gy
ST124SMA CW Power Sensor

ESD
Earth ground must be connected
Max pwr +23dBm avg, +30dBm peak for 1us +/- 10.0VDC Max.

10MHz - 12.4GHz
10nW - 100mW (-50dBm to 20dBm)

Unit Under Test (UUT)

Test signal source

Your PC

ST Sensor

USB
CableSignal cable
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Connecting multiple sensors
It is possible to connect and monitor multiple sensors. The number of sensors you can 
connect to your PC depends on your system configuration. For example, you may chose 
to use a USB hub interface. If this is the case, then carefully read the USB hub 
manufacturer’s instructions when connecting and configuring external USB devices.

Refer to Figure 17 "A typical multiple sensor configuration” on page 23 for a diagram of a 
typical multiple sensor configuration.

Figure 17 A typical multiple sensor configuration

tSa oriechno ol gy
ST124SMA CW Power Sensor

ESD
Earth ground must be connected
Max pwr +23dBm avg, +30dBm peak for 1us +/- 10.0VDC Max.

10MHz - 12.4GHz
10nW - 100mW (-50dBm to 20dBm)
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4 Using The Software
This chapter describes how to use the Satori Technology software when making typical 
power measurements. It also provides a description of the user interface and key features 
of the software.

Using the software
Once you have installed the software, configured your USB drivers and connected your 
hardware, you are ready to make measurements using the Satori Technology software.

If you chose the default installation, you should have an icon  on your desktop for the 
test software. Double-click on this icon to start the application. Refer to Figure 18 on page 
25 for an example start-up interface.

Figure 18 Default start-up interface

When the software is started, measurement results are displayed straight away. However 
you are reminded that you should zero the sensor.
25
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Zero your sensor
On the right side of the user interface you are reminded that the sensor is not zeroed. For 
more information on zeroing your sensor, refer to “What is zeroing?” on page 56. Use the 
following procedure to zero your measurement sensor:

Making a measurement
The following procedure outlines a typical measurement procedure.

Do this Comment

1 With the sensor still connected,

select the zero icon .

Or select Measurement 
> Zero Sensor

2 Confirm you wish to zero the sensor, select OK. Ensure no power is being 
applied to the sensor 
during this process.

3 Wait until the zeroing is completed. When the zero process is 
complete, the reminder is 
removed from the user 
interface.

Do this Comment

1 Zero the sensor. Refer to “Zero your 
sensor” on page 26.

2 Open the measurement control panel. Select the control 

panel icon or select Measurement > Control 
Panel.

Refer to Figure 19 on 
page 27.
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Figure 19 Control panel

3 Choose Log Power from the measurement mode 
section of the control panel dialog box.

Top left corner of the 
dialog box.

Figure 20 Log power

4 Enter the desired measurement frequency.

Figure 21 Set frequency

Do this Comment
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Using The Software
 For definitions of dB and dBm, refer to “What is a dB?” on page 57 and “What is a dBm?” 
on page 58.

Measurements using more than one sensor
It is possible to make multiple measurements using multiple USB sensors and multiple 
instances of the sensor software. Start the Satori Technology software for each sensor 
connected to your PC. Follow this procedure:

5 Choose Use Table in the calibration factor section of 
the control dialog box. This uses the sensor’s internal 
calibration table.

Refer to Figure 22 on 
page 28.

Figure 22 Use table

6 Select Apply and Close the measurement control 
panel.

Figure 23 Apply button

7 Enable the unit under test (UUT) providing a signal to 
the sensor.

8 The power measurement is displayed.

Do this Comment
28
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Do this Comment

1 Connect all your sensors to your PC.

2 Double-click on the desktop icon for the Satori 
Technology software.

3 To identify which sensor you are connected to, match 
the serial number on the display with the serial number 
on the sensor.

Refer to Figure 24 on 
page 29.

Figure 24 Sensor serial number identification

4 Configure your measurement software. Refer to “Making a 
measurement” on 
page 26.

5 Again, double-click on the desktop icon for the Satori 
Technology software and start another application.

6 Identify the sensor and configure your measurement.

7 Repeat this process (steps 2-4) for each sensor 
attached to your PC.
29
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How to make a pulse power measurement
The following procedure outlines how to set up and make a pulse power measurement. 
For more information on pulse power measurement refer to “Pulse measurement and 
setting the duty cycle” on page 56.

The pulse repetition rate should be above 200 Hz for the internal averaging to be 
effective. Below this pulse RF measurement (PRF), the reading will vary. The duty cycle 
feature may be used down to around 1%. The peak power limit of the sensor should 
however strictly be adhered to. Refer to Figure 26 on page 31 for more information.

Do this Comment

1 Open the application.

2 Zero your sensor. Refer to “Zero your 
sensor” on page 26.

3 Open the measurement control panel. Select the control 
panel icon or select Measurement > Control Panel.

4 Enable the duty cycle option and set the duty cycle 
percentage.

Refer to Figure 25 on 
page 30.

Figure 25 Setting the duty cycle

5 Set the Calibration Factor.

6 Select Apply.
30
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Figure 26 Typical RF burst

Measuring GSM mobile signals

GSM mobile signals are usually present for a single time-slot per frame, that is, for 
approximately one eighth of the time, since there are eight time slots per frame.

The mobile transmitter is active for slightly less than this time because the transmitter has 
around three 'tail' bits to ramp up and down in power, and 8.25 guard bits where the 
transmitter is silent. This means that the transmitter is inactive for 11.25 bits out of 156.25.

That is for roughly (156.25 - 11.25) / 156.25 = 0.928 of a time slot.

The duty cycle of the transmitter is then 12.5% * 0.928 = 11.6%. Refer to Figure 27 on 
page 32.

Note This measurement example is based on the ST124SMA sensor.

pulse period

on time

time

pulse power

average
power

duty cycle = 
on time

pulse period
100%

1
p.r.f. = pulse period

average power = 
on time

pulse power x

x

pulse period
Watts
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Figure 27 GSM TDMA structure and normal burst

In some cases, when the modulation is GPRS, multiple time slots are used. The correct 
duty cycle can be found by multiplying 11.6% by the number of active time-slots.

Making a measurement
Follow this procedure:

Do this Comment

1 Start the application.

2 zero the sensor. Refer to “Zero your 
sensor” on page 26.

3 Open the measurement control panel. Select the control 
panel icon or select Measurement > Control Panel.

4 Enable the duty cycle option and set the duty cycle 
percentage to 11.6%.

5 Select Apply. The sensor will read the 
GSM phone power in the 
active part of the time slot 
with reasonable 
accuracy.

8 1 2 3 4 5 6 7 8 1

TB
3

Data
57 57

DataTraining
26

f
1

f
1

TB
3

GB
8.25

1 TDMA frame (4.615 ms)

1 timeslot (0.577 ms)

TB = Tail Bits
f = Flag
GB = Guard Band
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Measuring power greater than +20dBm (100mW)

The offset facility is useful when an attenuator or amplifier is used ahead of the sensor.

For example, if a 10.00 dB attenuator could be placed before the sensor to measure 
powers up to +30dBm (1 Watt).

Caution Do not apply more than +20dBm directly to the sensor. This level of power 
will damage the sensor.

Do this Comment

1 Connect the sensor and open the application. Refer to “Making a 
measurement” on 
page 32.

2 Zero the sensor. Refer to “Zero your 
sensor” on page 26.

3 Set the measurement frequency. This is set in the 
measurement control 
panel.

4 Insert the RF attenuator in front of the sensor. The 
power reading decreases by the attenuation value.

5 In the measurement control panel, enable 
'Measurement Offset (dB)' and enter the value of the 
attenuator.

A positive number for 
attenuation, negative for 
gain.

6 The power reading will now increase by the value 
entered. This counteracts the decrease in the displayed 
reading caused by the attenuator. The offset value also 
appears on the application software.

7 The sensor and attenuator now measure from -40 dBm 
to +30 dBm. 

Refer to Figure 28 on 
page 34.
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Figure 28 Sensor configuration using an attenuator

Measuring an attenuator using relative mode
Use relative mode to measure an attenuator, similar to the type used when measuring 
power greater than +20dBm. The process is as follows:

Do this Comment

1 Connect the sensor and open the application. Refer to “Making a 
measurement” on 
page 32.

2 Zero the sensor. Refer to “Zero your 
sensor” on page 26.

3 Set the measurement frequency. This is set in the 
measurement control 
panel.

4 Connect the sensor to a signal generator and 
attenuator.

Set the signal generator 
level so that it will not 
damage to sensor, even 
without the attenuator.

5 In the measurement panel, enable relative 
measurement mode.

Refer to Figure 29 on 
page 35.

10dB
PAD+30 dBm

Offset

tSa oriechno ol gy
ST124SMA CW Power Sensor

ESD
Earth ground must be connected
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How to use measurement limits
The limit facility is useful for placing a guard band around a measurement.

For example, if the output from a device is +3dBm and must stay within 1dB of that level, 
then the limits facility can be used to warn you if the output rises above 4dBm or falls 
below 2dBm. Follow this procedure:

Figure 29 Enable relative measurement mode

6 Select the Set button. The display should be 
0.000 dB.

7 Remove the attenuator and reconnect the sensor to 
signal generator.

8 The sensor now reads the value of the attenuator, in dB, 
at the measurement frequency.

9 This value may be entered in the measurement offset.

Do this Comment

1 Connect the sensor and open the application. Refer to “Making a 
measurement” on 
page 32.

2 Zero the sensor. Refer to “Zero your 
sensor” on page 26.

Do this Comment
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If the level drops below 2dBm then a low limit warning message will appear. Refer to 
Figure 31 on page 37.

3 Set the measurement frequency. This is set in the 
measurement control 
panel.

4 In the measurement control panel, enable the limits 
options.

Refer to Figure 30 on 
page 36.

Figure 30 Setting measurement limits

5 Set the Low (dB) limit to 2dBm.

6 Set the High (dB) limit to 4dBm These limit settings are 
shown on the status area 
of the user interface.

Do this Comment
36
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Figure 31 Low limits warning message

If the level rise above 4dBm then a high limit warning message will appear. Refer to 
Figure 32 on page 37.

Figure 32 High limit warning message
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How to use trace mode
The trace facility is useful for plotting the level being measured by the sensor over a 
period of time.

To configure a trace, open the trace control dialog box. Select the trace icon  or 
select Tools > Trace...

The trace is configured as follows:

Do this Comment

1 Set the number of samples. This is the number of samples to be 
taken for the trace.

2 Set the sample period. This is the time between the plotted 
points. Refer to Figure 33 on page 38.

Figure 33 Trace control dialog box

3 Set the plot type. Power linear (watts) or power log 
(dBm).
38
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While the trace is drawing, the scaling can be altered by selecting the settings icon or 
selecting Trace > Settings on the menu bar. Also, the trace can be stopped by selecting 
the stop icon or selecting Trace > Stop on the menu bar. Refer to Figure 35 on page 40.

4 Set the plot scaling to Auto. The Y-axis is automatically scaled to 
suit the Min and Max values 
associated with the level being 
plotted.

5 (Optional) Disable plot scaling. The Y-axis uses the entered Min and 
Max values.

6 Set temperature display, enable the sensor 
option.

The temperature is displayed with a 
red trace.

7 (Optional) Enable the Auto Scale option. The Y-axis is automatically scaled to 
suit the Min and Max temperature 
values.

If auto scaling is not selected, then 
Min and Max values for the 
temperature Y-axis can be entered 
into the Min and Max boxes.

8 Select Start to begin the real-time trace. Refer to Figure 34 on page 39.

Figure 34 Typical trace with temperature

Do this Comment
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Figure 35 Trace settings dialog box

When the trace is complete, markers for making X & Y measurements can be turned on 
by selecting the markers icon or selecting Trace > Markers in the menu bar. Refer to 
Figure 36 on page 40.

Figure 36 Trace markers

The displayed trace can be saved by selecting the File > Save Trace in the trace control 
dialog box. A trace can be recalled by selecting File > Recall Trace. The raw data used to 
draw the trace can be saved in a file by selecting the Save Data icon.

To exit trace mode select the exit icon or select Trace > Exit.
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Note Do not select the window close icon at the top right of the application to exit 
the trace feature as this closes the whole application. Instead select the 
close icon .
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Error and status messages
The right side of the users interface displays a series of warnings and status messages. 
These are described as follows:

Sensor not zeroed
This message is displayed when the application first 
detects a sensor or the sensor needs to be re-zeroed. 
Refer to “Zero your sensor” on page 26 for more 
information. Refer to Figure 37 on page 42.

Sensor frequency, offset and duty 
cycle enabled
These message let you know your measurement 
frequency setting. It also shows if offset has been 
enable along with the duty cycle. Refer to Figure 37 on 
page 42.

Figure 37 Frequency, Offset 
and Duty Cycle messages
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Sensor overload
This warning message indicates a sensor overload. 
Refer to Figure 38 on page 43.

Figure 38 Sensor overload 
warning message

High limit exceeded
This warning message tells you when you have 
exceeded the high measurement limit you have set in 
the measurement control panel. When you see this 
warning message, reduce the power being tested. 
Refer to Figure 39 on page 43.

Figure 39 High limit warning
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Low limit exceeded
This warning message tells you when you have 
exceeded the low measurement limit you have set in 
the measurement control panel. When you see this 
warning message, increase the power being tested. 
Refer to Figure 40 on page 44.

Figure 40 Low limit warning

Zero sensor - temperature change
When the temperature of the sensor is too great for the 
reliable measurement to be made, the zero sensor and 
temperature warning message is displayed. Refer to 
Figure 41 on page 44.

Figure 41 Zero shift warning
44



User’s Guide
Manually entered cal factor
When you have entered a cal table, the entries are 
displayed on the user interface. Refer to  on page 45.

Manually entered cal table
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Description of software
The following section describes the basic software features. For more information on the 
software and menu options, refer to the online help in the application.

Description of icons
The icons, along the top of the application, are used for accessing the most common 
tasks. The icons are used as follows:

Icon Description

Opens the control panel.

Starts the zero sensor process.

Sets the sensor frequency.

Changes the display between dBm nW.

Changes the display between numerical or numerical with graphical data 
display to just a graphical display.

Changes the number of decimal places being displayed.

Opens the trace setting dialog box.

Saves the current data.

Recalls (Open) saved data.

Opens the application help.
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Description of menu options
The following describes the menu options from the application.

File Menu
Save Setup

Allows current setup to be saved to a simple text file.

Recall Setup
Allows a previous setup to be recalled.

Firmware download
Lets you update the firmware revision of the sensor.

Exit
Exits the application.

Measurement Menu
Control Panel

The control panel is used for setting most of the user interface components and 
key measurement factors. The control panel is divided into areas for 
configuring your measurement environment.

Zero Sensor
This performs a sensor zeroing process and will remove any offsets before 
making a measurement. This function should be carried out typically for values 
less than -35dBm. Refer to “What is zeroing?” on page 56 for more 
information.

Preset
Resets all your configured measurements back to the factory default settings.

Tools Menu
Trace

Opens the trace control dialog box. Configure and start your trace from this 
dialog box.

Stats
This opens the statistics configuration dialog box. From this dialog box you can 
setup and draw a snap-shot bar chart of your results.
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Calculators
This menu option gives you access to three useful microwave calculators. 
These are:

• VSWR Mismatch
• Parameters
• Power Units Converter

The VSWR Mismatch calculator and the Parameter calculator have help files 
which describe their operation.

Help Menu
USB Power Sensor Help

Opens the application help which provides detailed descriptions of the features 
being used. Help on the measurement control panel is displayed when you 
select the help button in the dialog box. 

Sensor Details
Provides information about the detected sensor being used by the application. 
This includes the firmware and serial number of the sensor.

About…
This provides information about the revision of the application you are using.
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5 Enhanced Features
This chapter outlines the advanced capabilities of the ST CW power sensor software. 
There are brief outlines and descriptions of how the software can be integrated into other 
test environments such as C++, Agilent VEE and National Instruments® NI.

Refer to the programming reference guide for more details (S2004-90012). An electronic 
version is included on your Satori Technology CD.

Integrating your power sensor
The following section details how to integrate the Satori Technology software into your 
test environment.

A library of function calls provides a simple, but powerful interface between your 
application software and sensor hardware. All the function calls are contained in a 
dynamic link library (DLL).

To use the library, the following three files are required:

• USB Sensor Lib.dll
• USB Sensor.Lib.lib
• USB Sensor.h

These files can be found on the installation CD. The latest versions can be downloaded 
free of charge from the Satori website www.satori-technology.com

The file USB Sensor Lib.dll can reside in the same directory as your application 
executable file, or in a path known to your application executable file.

The file USB Sensor Lib.lib must reside in a path known to the linker that will link to your 
application.

The file USB Sensor.h contains definitions required by the USB Sensor function calls and 
must reside in a path known to the compiler that will compile your source code.
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6 Troubleshooting
This chapter explains how to fix some typical software and hardware configuration issues 
that you may have encountered. It also provides some technical background information 
that can help you better understand your test environment.

How to fix “No Sensor Connected” problems
When you start your Satori Technology software application you can get the following 
condition message displayed - “No Sensor Connected”, refer to Figure 42 on page 51.

Figure 42 No sensor connected warning

This can be the result of one of the following issues:

• No sensor is attached to your PC (refer to page 52)
• The wrong USB driver has been installed (refer to page 52)
• The USB cable or USB port are faulty (refer to page 53)
• Incorrectly configured USB hub (refer to page 53)
• More than one application has been started (refer to page 54)

The following procedures will help you correct these problems:
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No sensor is attached to your PC
Check all cable connections from your PC to your sensor. A connector may have been 
loosened and may not be making adequate contact.

This is especially important when using multiple sensor configurations.

The wrong USB driver has been installed
If the wrong USB driver has been installed then there will be no consistent communication 
between your sensor and PC. Use the following procedure to identify the installed driver. 
This procedure applies to Windows® XP operating system.

Do this Comment

1 On your PC, select Start > Control Panel.

2 Double-click on System. This opens the System 
Properties dialog box.

3 Select the Hardware tab.

4 Select the Device Manager button. This opens the Device 
Manager dialog box.

5 Expand the list of Universal Serial Bus controllers Click the ‘plus’ symbol to 
expand the list.

6 If the correct driver has been installed you should see 
the following item listed - FTDI FT8U2XX Device

Refer to Figure 43 on 
page 52.

Figure 43 Correct USB driver configuration
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If this is NOT the driver listed in your Device Manager, then use the following procedure to 
remove the installed driver and configure the correct driver:

The USB cable or USB port are faulty
In the event of a faulty cable or port, try the following solutions:

• Replace the cable with another high standard USB cable.
• Use another USB port on your PC. If you only have one port on your PC, connect 

another USB device to the suspected port (for example a mouse or printer) and 
verify device recognition.

Incorrectly configured USB hub
Some USB hub devices require custom driver installation. If the driver installation 
procedures are not followed correctly some, or all the ports provided by the hub, may not 
be seen by your PC.

Carefully read your USB hub manufacturer’s instructions on driver installation and 
configuration.

If you are not sure the fault is with the USB hub, try connecting a sensor directly to your 
PC and verify connection using the application.

Do this Comment

1 Disconnect any sensors connected to your PC.

2 On your PC, select Start > Control Panel.

3 Double-click on Add or Remove Programs.

4 Locate and select the FTDI COM driver listed.

5 Select the Change/Remove button. This removes the USB 
driver.

6 When the driver has been removed, close the Add or 
Remove Programs dialog box.

7 Close the Control Panel.

8 To install the correct USB, refer to “USB Installation” on 
page 13.
53



Troubleshooting
More than one application has been started
It is possible to start multiple instances of the application software. The first time the 
application is started it checks the available USB ports for a recognised sensor.

If the application is started again, but you only have one sensor connected, then the 
application will report a “No Sensor Connected” error.

Check your PC Taskbar for any minimised applications.

Unexpected measurements results
If you suspect that you are getting unexpected measurements, then use the following 
procedures to correct the potential fault:

• Check the status messages displayed on the right-side of the application
• Your sensor is potentially damaged
• Incorrect offset setting
• Incorrect measurement settings

Check status messages
The status messages on the right-side of the application provide information about your 
measurement settings and any possible limits errors. Refer to “Error and status 
messages” on page 42.

Your sensor is potentially damaged
If you suspect that your sensor is damaged, then connect a known signal source and 
verify that the sensor is measuring that source correctly. If this, or any of the other 
procedures do not correct the fault then contact your local representative for more 
information.

Incorrect offset setting
If you have made the wrong measurement offset setting in the measurement control 
panel, then you may see incorrect measurements.

Incorrect measurement settings
Check that you have set all the right settings in the measurement control panel. Refer to 
“Using the software” on page 25 for more information. If you are not sure what settings 
you have set, select Measurement > Preset to return the sensor measurement settings 
to the factory default settings.
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How to identify your PC operating system
The procedure for installing USB drivers differs slightly depending on which version of 
operating system you have on your PC. Follow this procedure to identify your operating 
system.

Do this Comment

1 On your PC, select Start.

2 Highlight and right-click on My Computer.

3 Select Properties from the pop-up menu. This opens the System 
Properties dialog box.

4 Select the General tab. Refer to Figure 44 on 
page 55.

Figure 44 How to identify your operating system

Your operating system

Installed service pack
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Other useful information
The following sections provide some useful information about power measurement and 
your USB sensor.

What is zeroing?
Zeroing is a measurement process that ensures that the sensor indicates as close as 
possible to 0 watts when no power is applied. This ensures that the sensor gives the best 
possible linearity.

Due to the very low voltages that are measured by the analogue to digital converter in the 
sensor, some averaging is necessary and the process takes about eleven seconds. The 
zero should be re-measured periodically for best accuracy at low power levels. It should 
also be re-measured after connecting the sensor directly to equipment that is at a 
significantly different temperature than the sensor, when the sensor has reached 
operating temperature.

It is only necessary to re-zero if the power indicated when no power is applied to the 
sensor is worse than -55 dBm. A poor zero affects lower power measurements more than 
larger ones. Excessive zeroing in automatic measurement programs is not recommended 
as it can significantly increase program run times.

Pulse measurement and setting the duty cycle
The duty cycle facility is used to measure the 'pulse power'. This is the power 
measurement while an RF burst is present, when the signal is a gated burst of a 
sinusoidal RF signal - for example a radar pulse.

The sensor is calibrated to measure average power, and provided the pulse repetition 
rate is sufficiently high, a measurement of the pulse power can be obtained from the 
average power.

Certain assumptions are made about the RF burst, and these must be met if the 
measurement is to be accurate. The burst is assumed to be either on or off, in other words 
it does not take a finite time to ramp up or down.

The ramp up and down times should be small in relation to the on time of the signal 
generator. The burst is also assumed to have constant amplitude when on. The amplitude 
does not ring, droop or overshoot. If the pulse does not have these attributes, then the 
accuracy of the result is not valid.

The RF in the burst is also assumed to be un-modulated. If it were amplitude modulated, 
for example, then the measurements would be likely to vary with time as the modulation 
and the voltage measurement made in the power meter would not be synchronized. 
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Constant amplitude modes of modulation like phase or frequency modulation are 
permissible.

What is a dB?
The dBm and dB are common units occurring in power measurements. 'dB' is short for 
decibel. The dB is a method of describing the ratio of two powers over a very wide range 
and is defined as:

The table below gives some power ratios and their equivalent dB values:

Power ratio dB
0.001 -30.00
0.01 -20.00
0.1 -10.00
0.25 -6.02
0.5 -3.01
1 0
2 3.01
4 6.02
10 10.00
100 20.00
1000 30.00

⎟⎟
⎠

⎞
⎜⎜
⎝

⎛
=

2

1
10log*10

P
P

dB
57



Troubleshooting
What is a dBm?
When one of the powers is defined, again for convenience, as 1mW, then the related unit, 
abbreviated to 'dBm', is described as follows.

The table below gives some powers and their equivalent dBm values:

Power dBm
1 µW -30.00
10 µW -20.00
100 µW -10.00
0.25 mW -6.02
0.5 mW -3.01
1 mW 0
2 mW 3.01
4 mW 6.02
10 mW 10.00
100 mW 20.00
1 W 30.00

⎟
⎠
⎞

⎜
⎝
⎛=

mW
PdBm

1
log*10 1

10
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7 Contact & Support
This chapter provides information about Satori Technology. It tells you how to get in touch 
and what to do if you are having problems or need more information about other products.

Contacting Satori Technology
To contact Satori Technology please contact your local representative or use the following 
e-mail address:

support@satori-technology.com

Our Website
The Satori Technology website provides up to date product information and news.

www.satori-technology.com
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8 Safety & Specifications
This chapter provides information about the ST CW power sensor safety compliance and 
sensor specifications.

Safety notices
Please careful read the following information:

WARNING A WARNING denotes a hazard. A WARNING that is not followed and 
adhered to could result in injury or loss of life. Do not proceed 
beyond the WARNING note until you have carefully read and 
understood the note.

Caution A CAUTION denotes a hazard. A CAUTION that is not followed and 
adhered to could result in partial or complete damage of your equipment. 
Do not proceed beyond the CAUTION note until you have carefully read 
and understood the note.

Note A NOTE draws your attention to a procedure or additional information that, 
if followed correctly, can prevent mis-use of the your equipment. It also 
points out additional information that can help you get more from your 
system.
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WEEE Directive
Satori Technology will undertake a “take back” policy for all sensor products no longer fit 
for purpose and dispose of the said products under the European WEEE directive.

Please contact Satori Technology for more details, refer to “Contacting Satori Technology” 
on page 59.

Product descriptions and requirements
The ST CW power sensor descriptions and PC specifications are as follows:

Minimum PC requirements
Your minimum recommended PC specifications are:

PIII Windows XP SP2
256 RAM
600 MHz
USB Port (1.0 or greater)
CD Drive

ST124SMA Description
• ST124SMA USB power sensor
• Frequency range: 10MHz to 12.4GHz
• Amplitude range: -50dBm to +20dBm
• RF input connector SMA male

ST185SMA Description
• ST185SMA USB power sensor
• Frequency range: 10MHz to 18.5GHz
• Amplitude range: -50dBm to +20dBm
• RF input connector SMA male

ST265SMA Description
Contact your local Satori Technology representative for more information.
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